設定時の複数インターフェースの指定について

質問内容

こんにちは。以下質問をさせていただきます。
Cloud Router Switch で設定をする際に、以下の内容でインターフェースを複数選択して設定したいのですが、GUI/CLI ともに複数インターフェースを一気に設定することができないようです。一つづつポチポチ設定するか、複数行コマンドを入れる、スクリプトを組む以外に方法はないでしょうか。

  • Bridge の Ports に ether1 から ether 10 までを入れる。

  • Interface List に ether1 から ether 10 までを入れる。

  • Bridge の VLANs 内の VLAN 設定の Tagged/Untagged に ether1 から ether 10 までを入れる。

  • ether1 から ether 10 までのインターフェースの MTU を 9000 に変える。

Cisco スイッチの interface range コマンド のような使用感で使えるとありがたいのですが。。

対象routerboard

CRS326-24S+2Q+RM

対象OSバージョン

ROS 6.48.3

対象Firmware

ROS 6.48.3

1 Like

お世話になります。

GUI/CLI ともに複数インターフェースを一気に設定することができないようです。一つづつポチポチ設定するか、複数行コマンドを入れる、スクリプトを組む以外に方法はないでしょうか。

私も昔から悩んでいますが全てを満たす回答は多分無いと思います。それぞれ使い分ける、または組み合わせる必要があるかと思います。

  • Bridge の Ports に ether1 から ether 10 までを入れる。

前提として/interface list を使用し、対象とするインターフェースをグループ化します。

; グループ化する"TEST"を作成
/interface list
add name=TEST

; ether1から10をlist "TEST" に追加する
/interface list member
:for i from=1 to=10 do={
	:put [add interface="ether$i" list=TEST]
}

Interface List に ether1 から ether 10 までを入れる。

先にグループ化したものはbridgeのポートで指定できます。Interface-listでグループ化しておけば、この辺りは使い回せるので良いかと思います。

/interface bridge port
add bridge=bridge1 interface=TEST

Bridge の VLANs 内の VLAN 設定の Tagged/Untagged に ether1 から ether 10 までを入れる。

VLANについては、Tagged/Untagged ではInterface-listが使用できないので、 @wndws さんの言うとおりポチポチかCLIで一つづつ設定するか、上記のようなScriptを使うなどしか解決出来ないかと思います。

ether1 から ether 10 までのインターフェースの MTU を 9000 に変える。

これも同様ですね。
ただ、なぜかこっちではnameで指定できないので、number (0から始まるindexに注意)
で指定する必要があるかと思います。

:for i from=0 to=9 do={
	:put [set mtu=9000 numbers=$i ]
}

このあたりは公式に改善のリクエストは必要かもしれませんね・・・。
回答になっているでしょうか?

1 Like

早速の回答ありがとうございます。

スクリプトのサンプルまでつけていただいて大変助かります。

どうもありがとうございました。

1 Like