RouterOSでのTrunk設定について

質問内容

Trunkの設定を調べながら実施しているのですが、正しい設定ができません。
皆様のお力をお貸し頂ければと思います。


画像のような構成でRouterBoardで複数のTrunkポートを作成したいのですが、
インターフェースにVlanを割り当てているポートでIPを振っているVlan5、Vlan10は動作するのですが、IPを振っていないVlan4000はうまく動作していないようです。
また、ブリッジさせたポートの方は全く動作していないようです。
抜粋したコンフィグは下記になります。※ほかに必要なものがありましたらコメントをお願いします。

/interface bridge
add ageing-time=5m arp=enabled arp-timeout=auto auto-mac=yes dhcp-snooping=no \
    disabled=no ether-type=0x8100 fast-forward=yes forward-delay=15s frame-types=\
    admit-only-untagged-and-priority-tagged igmp-snooping=no ingress-filtering=no \
    max-message-age=20s mtu=auto name=BR-trunk priority=0x8000 protocol-mode=rstp \
    pvid=1 transmit-hold-count=6 vlan-filtering=yes
add ageing-time=5m arp=enabled arp-timeout=auto auto-mac=yes dhcp-snooping=no \
    disabled=no fast-forward=yes forward-delay=15s igmp-snooping=no max-message-age=\
    20s mtu=auto name=BR-vlan5 priority=0x8000 protocol-mode=rstp \
    transmit-hold-count=6 vlan-filtering=no
add ageing-time=5m arp=enabled arp-timeout=auto auto-mac=yes dhcp-snooping=no \
    disabled=no fast-forward=yes forward-delay=15s igmp-snooping=no max-message-age=\
    20s mtu=auto name=BR-vlan4000 priority=0x8000 protocol-mode=rstp \
    transmit-hold-count=6 vlan-filtering=no
/interface ethernet
set [ find default-name=ether1 ] advertise=\
    10M-half,10M-full,100M-half,100M-full,1000M-half,1000M-full arp=enabled \
    arp-timeout=auto auto-negotiation=yes bandwidth=unlimited/unlimited disabled=no \
    full-duplex=yes l2mtu=1592 loop-protect=default loop-protect-disable-time=5m \
    loop-protect-send-interval=5s mac-address=08:55:31:57:8C:7C mtu=1500 name=\
    ether1_1F-StoragePSW_Gi16 orig-mac-address=08:55:31:57:8C:7C rx-flow-control=off \
    speed=1Gbps tx-flow-control=off
set [ find default-name=ether10 ] advertise=\
    10M-half,10M-full,100M-half,100M-full,1000M-half,1000M-full arp=enabled \
    arp-timeout=auto auto-negotiation=yes bandwidth=unlimited/unlimited disabled=no \
    full-duplex=yes l2mtu=1592 loop-protect=default loop-protect-disable-time=5m \
    loop-protect-send-interval=5s mac-address=08:55:31:57:8C:85 mtu=1500 name=\
    ether10_2F-WorkPSW_Gi1 orig-mac-address=08:55:31:57:8C:85 poe-out=off \
    poe-priority=10 power-cycle-interval=none !power-cycle-ping-address \
    power-cycle-ping-enabled=no !power-cycle-ping-timeout rx-flow-control=off speed=\
    1Gbps tx-flow-control=off
set [ find default-name=sfp-sfpplus1 ] advertise="" arp=enabled arp-timeout=auto \
    auto-negotiation=yes bandwidth=unlimited/unlimited disabled=no full-duplex=yes \
    l2mtu=1600 loop-protect=default loop-protect-disable-time=5m \
    loop-protect-send-interval=5s mac-address=08:55:31:57:8C:86 mtu=1500 name=\
    sfp-sfpplus1_NTT orig-mac-address=08:55:31:57:8C:86 rx-flow-control=off \
    sfp-rate-select=high sfp-shutdown-temperature=95C speed=10Gbps tx-flow-control=\
    off
/interface vlan
add arp=enabled arp-timeout=auto disabled=no interface=ether1_1F-StoragePSW_Gi16 \
    loop-protect=default loop-protect-disable-time=5m loop-protect-send-interval=5s \
    mtu=1500 name=vlan5 use-service-tag=no vlan-id=5
add arp=enabled arp-timeout=auto disabled=no interface=ether1_1F-StoragePSW_Gi16 \
    loop-protect=default loop-protect-disable-time=5m loop-protect-send-interval=5s \
    mtu=1500 name=vlan10 use-service-tag=no vlan-id=10
add arp=enabled arp-timeout=auto disabled=no interface=ether1_1F-StoragePSW_Gi16 \
    loop-protect=default loop-protect-disable-time=5m loop-protect-send-interval=5s \
    mtu=1500 name=vlan4000 use-service-tag=no vlan-id=4000
/interface bridge port
add auto-isolate=no bpdu-guard=no bridge=BR-vlan4000 broadcast-flood=yes disabled=no \
    edge=auto fast-leave=no frame-types=admit-all horizon=none hw=yes \
    ingress-filtering=no interface=sfp-sfpplus1_NTT internal-path-cost=10 learn=auto \
    multicast-router=temporary-query path-cost=10 point-to-point=auto priority=0x80 \
    pvid=4000 restricted-role=no restricted-tcn=no tag-stacking=no trusted=no \
    unknown-multicast-flood=yes unknown-unicast-flood=yes
add auto-isolate=no bpdu-guard=no bridge=BR-vlan4000 broadcast-flood=yes disabled=no \
    edge=auto fast-leave=no frame-types=admit-all horizon=none ingress-filtering=no \
    interface=vlan4000 internal-path-cost=10 learn=auto multicast-router=\
    temporary-query path-cost=10 point-to-point=auto priority=0x80 pvid=4000 \
    restricted-role=no restricted-tcn=no tag-stacking=no trusted=no \
    unknown-multicast-flood=yes unknown-unicast-flood=yes
add auto-isolate=no bpdu-guard=no bridge=BR-trunk broadcast-flood=yes disabled=no \
    edge=auto fast-leave=no frame-types=admit-all horizon=none hw=yes \
    ingress-filtering=no interface=ether1_1F-StoragePSW_Gi16 internal-path-cost=10 \
    learn=auto multicast-router=temporary-query path-cost=10 point-to-point=auto \
    priority=0x80 pvid=1 restricted-role=no restricted-tcn=no tag-stacking=no \
    trusted=no unknown-multicast-flood=yes unknown-unicast-flood=yes
add auto-isolate=no bpdu-guard=no bridge=BR-trunk broadcast-flood=yes disabled=no \
    edge=auto fast-leave=no frame-types=admit-all horizon=none hw=yes \
    ingress-filtering=no interface=ether10_2F-WorkPSW_Gi1 internal-path-cost=10 \
    learn=auto multicast-router=temporary-query path-cost=10 point-to-point=auto \
    priority=0x80 pvid=1 restricted-role=no restricted-tcn=no tag-stacking=no \
    trusted=no unknown-multicast-flood=yes unknown-unicast-flood=yes
add auto-isolate=no bpdu-guard=no bridge=BR-vlan5 broadcast-flood=yes disabled=no \
    edge=auto fast-leave=no frame-types=admit-all horizon=none hw=yes \
    ingress-filtering=no interface=ether9 internal-path-cost=10 learn=auto \
    multicast-router=temporary-query path-cost=10 point-to-point=auto priority=0x80 \
    pvid=1 restricted-role=no restricted-tcn=no tag-stacking=no trusted=no \
    unknown-multicast-flood=yes unknown-unicast-flood=yes
add auto-isolate=no bpdu-guard=no bridge=BR-vlan5 broadcast-flood=yes disabled=no \
    edge=auto fast-leave=no frame-types=admit-all horizon=none ingress-filtering=no \
    interface=vlan5 internal-path-cost=10 learn=auto multicast-router=temporary-query \
    path-cost=10 point-to-point=auto priority=0x80 pvid=1 restricted-role=no \
    restricted-tcn=no tag-stacking=no trusted=no unknown-multicast-flood=yes \

対象routerboard

RB4011iGS+

対象OSバージョン

6.49.6

対象Firmware

6.49.6

こんにちは。

設定を拝見しましたが、ブリッジは一つで良さそうに思いますね。
意図を読み違えていたら申し訳ないのですが、私の考えた設定例を以下に記載します。
最小限の内容になっていますので、あくまで参考ということでお読み頂ければと思います。

ちなみに作業をされる際は、ブリッジへ参加させないポートに作業用のIPアドレスを設定して、そこへ繋いだ端末から実施するのが良いと思います。


まず単一のブリッジをVLANフィルタリング無効で作成します。

/interface bridge
add name=bridge1 vlan-filtering=no

次に、ether1とether10とsfp-sfpplus1をブリッジポートとして追加します。
(スイッチチップを跨ぐブリッジになるのでHW処理が効かなくなる気がしますが…まあ置いといて)

/interface bridge port
add bridge=bridge1 interface=ether1 pvid=1 ingress-filtering=yes frame-types=admit-only-vlan-tagged
add bridge=bridge1 interface=ether10 pvid=1 ingress-filtering=yes frame-types=admit-only-vlan-tagged
add bridge=bridge1 interface=sfp-sfpplus1 pvid=4000 ingress-filtering=yes frame-types=admit-only-untagged-and-priority-tagged

ether1とether10はトランクポートとしてタグつきのパケットのみ受け付けるようにしています。
sfp-sfpplus1はVLAN:4000のアクセスポートとしてタグなしのパケットのみ受け付けます。

そして、VLAN IDとブリッジポートを関連付けます。

/interface bridge vlan
add bridge=bridge1 tagged=bridge1,ether1,ether10 vlan-ids=5
add bridge=bridge1 tagged=bridge1,ether1,ether10 vlan-ids=10
add bridge=bridge1 tagged=bridge1,ether1,ether10 untagged=sfp-sfpplus1 vlan-ids=4000

VLAN:5と10はブリッジ内およびether1,ether10にタグ付きのまま流します。
VLAN:4000も同様ですが、sfp-sfpplus1に出ていくときはタグを外します。

最後に、ブリッジのVLANフィルタリングを有効にします。
これでブリッジがVLANを処理するようになります。

/interface bridge set bridge1 vlan-filtering=yes

各VLANにルーター自身が参加して通信するために、ブリッジにVLANインターフェイスを作成します。

/interface vlan
add interface=bridge1 name=vlan5 vlan-id=5
add interface=bridge1 name=vlan10 vlan-id=10
add interface=bridge1 name=vlan4000 vlan-id=4000

IPアドレスやルーティング、ファイアウォールも適宜。


私は7系のOSしか触っていないので、6系で通用するかあまり自信がなく…。
お役に立てると良いのですが。

1 Like

ありがとうございます。

頂きました設定を投入したところ無事にTrunkとして動作させることができました。

ちなみにですが、sfp-sfpplus1でNTTからの回線を受けており、内部的にvlan4000として利用しています。
以前はvlan4000とブリッジさせたインターフェースにてipv6を受けていたのですが、
頂いた設定ではvlan4000を利用すればよいかと思っているのでが、
うまくプレフィックスが落ちてきません。落ちてこない原因は何なのでしょうか。

契約は光電話ありとなります。

2 Likes

原因はわかりませんが、自己解決しました。

一度旧設定に戻しDHCPv6Clientで受けていたものをreleaseしてから
新設定にしたところ無事にプレフィックスを受信できました。

2 Likes

良かった!解決したのですね。
お疲れ様でした!

一度旧設定に戻しDHCPv6Clientで受けていたものをreleaseしてから

よく思い付かれましたね…。すごい。