RouterOS 7.1なRBにWindows PCからL2TP/IPsecでうまく接続出来ない

RouterOS 6.49.1 から7.1にアップグレードしたところ、Windows 10 PCからL2TP/IPsecによる接続が出来なくなりました。
設定を見直したところ、何とか接続出来るようになりました。

確認環境

[[email protected]] /system/resource> print 
             uptime: 3d1h14m12s
            version: 7.1 (testing)
         build-time: Dec/01/2021 14:07:27
        free-memory: 1609.9MiB
       total-memory: 1952.0MiB
                cpu: tilegx
          cpu-count: 9
      cpu-frequency: 1200MHz
           cpu-load: 0%
     free-hdd-space: 82.7MiB
    total-hdd-space: 128.0MiB
  architecture-name: tile
         board-name: CCR1009-8G-1S-1S+
           platform: MikroTik

設定内容(必要部分抜粋)

/interface/l2tp-server
add name=l2tp-in1 user=<接続ユーザー名>
/interface l2tp-server server
set authentication=chap,mschap2 default-profile=profile1 enabled=yes \
    keepalive-timeout=60 max-mru=1280 max-mtu=1280
/ppp/profile
add bridge=bridge1 dns-server=192.168.88.1 \
    idle-timeout=1h local-address=192.168.88.1 name=profile1 \
    remote-address=vpn-ipsec use-encryption=yes use-ipv6=default
/ip ipsec mode-config
set [ find default=yes ] use-responder-dns=yes
add address-pool=vpn-ipsec name=cfg1
/ip ipsec peer
add comment="Windows VPN" local-address=<WAN IP> name=peer1 passive=yes
/ip ipsec profile
set [ find default=yes ] dpd-interval=1m enc-algorithm=aes-256,aes-192,aes-128,3des \
    lifetime=8h
/ip ipsec proposal
set [ find default=yes ] enc-algorithms=aes-256-cbc,aes-128-cbc,3des
/ip ipsec identity
add auth-method=pre-shared-key comment="Windows VPN" disabled=no generate-policy=\
    port-override mode-config=cfg1 notrack-chain=prerouting peer=peer1 secret=\
    <共通鍵>
  • 調査時は /system/loggingdebug フラグを設定してlogに何か出ないか確認してください
  • 出来ればipsec周りの設定は使い回さずに作り直した方が良いかもしれません。

未調査

  • v6 → v7へのアップグレード時に正常にパスワード周りが変換されていないんじゃないか疑惑

今更ですがRouterOS 7.1.1では接続出来るようになりました。