RouterOSv7でv6プラスでの接続が確立できない

質問内容

RouterOS 6.49beta54から7.1rc1に切り替えてみたところ、v6プラスのipip6トンネルインターフェースが動作動作しなくなりました。upとdownを繰り返す状況です。
Webを見ているとIPoEなどで動作できている方はいらっしゃるみたいなので、この辺りについてノウハウがある方は教えていただけと嬉しいです。

ちなみに6.49beta54では問題なく動作していることは確認済みです。

対象routerboard

  • CCR1009-8G-1S-1S+

対象OSバージョン

こんにちは。
(初めましてです。よろしくお願いいたします)

まず、OSはアップグレードでしょうか。
新規インストールでしょうか。

アップグレードの場合、パッケージの更新だけでなくファームウェアの更新も行われましたか?
そして、旧バージョンから引き継がれた設定は見直されましたか?

私は7.1beta6からrc1へのアップグレードでコンフィグが部分的に壊れる事象を経験しており、Gitで管理している以前のコンフィグと差分を取って手動で直しました。
IPIPやファイアウォールの設定にまで影響していたかは記憶にないのですが、その辺が壊れた可能性はあるかも知れません…。

新規インストールの場合だと、なんだろう…。

また、これはフレッツ側の仕様かとは思いますが、PPPoEやIPIPはこちらが使用するインターフェース(のおそらくMACアドレス)が変わった場合に最長で30分ぐらい繋がらないことがありますね。

反応ありがとうございます。

まず、OSはアップグレードでしょうか。
新規インストールでしょうか。

6.49beta54 → 7.1rc1へのアップグレードですね。ファームウェアについても合わせないと不具合が発生する可能性が高いのは経験済みなのでOSのアップグレードと合わせて実施しました。

私は7.1beta6からrc1へのアップグレードでコンフィグが部分的に壊れる事象を経験しており、Gitで管理している以前のコンフィグと差分を取って手動で直しました。
IPIPやファイアウォールの設定にまで影響していたかは記憶にないのですが、その辺が壊れた可能性はあるかも知れません…。

パラメータの互換性がない(なぜか公式が変換にミスる)ことによるconfigの修正が余儀なくされるのは、今回詳細に調査していませんでした。ただ、トンネルインターフェース自体のパラメータは入れ直しを行えたので大丈夫かと思っています。

また、これはフレッツ側の仕様かとは思いますが、PPPoEやIPIPはこちらが使用するインターフェース(のおそらくMACアドレス)が変わった場合に最長で30分ぐらい繋がらないことがありますね。

ぐえ、フレッツのこんな仕様があるんですね・・・。30分は待っていなかったので、少し時間に余裕があるときに再度確認してみようかと思います。

1 Like

以下のエラーメッセージを繰り返しているのを確認しました。

<ipipv6トンネルインターフェース> transmit loop detected, downing interface for 60 seconds`

公式フォーラムでは6to4トンネルインターフェースで同じような症状があり、どうやら7.1rc1どころか過去バージョンでも駄目な模様。

I updated SUP-49921 with a test on 7.1rc1
6.48.4 → works as expected
7.1rc1 → DOES NOT work (same as 7.1beta6 and 7.1beta5)

https://forum.mikrotik.com/viewtopic.php?f=2&t=175295&p=857556&hilit=transmit+loop+detected%2C+downing+interface+for+60+seconds#p857556

というわけで、ROS7.1ではまたv6プラス環境へ移行は出来ない気がしてきました。もう少し様子見が必要なようです。

公式フォーラムでは6to4トンネルインターフェースで同じような症状があり、どうやら7.1rc1どころか過去バージョンでも駄目な模様。

私のCCR2004-1G-12S+2XSでは7.1rc1からのv6プラス接続ができているので、
機種や設定の差により発生する事象なのかもしれませんね。

参考になるかわかりませんが、私の設定から関連しそうな部分を抜き出しました。
実際にはファイアウォールやルーティングルールなど結構複雑化していますが、とりあえずこの例では無いものとして、とにかくリンクアップするであろう最低限です。

# NGNとLANのブリッジ(ひかり電話契約ではないため)
/interface bridge
add ingress-filtering=no name=bridge-ngn protocol-mode=none

/interface ipipv6
add !keepalive local-address=<例の計算機で求めたCEのv6アドレス> mtu=1460 \
    name=ipipv6-v6plus remote-address=<例の計算機で求めたBRのv6アドレス>

/interface bridge port
add bridge=bridge-ngn ingress-filtering=no interface=sfp-sfpplus12
add bridge=bridge-ngn ingress-filtering=no interface=sfp-sfpplus10

/ipv6 settings
set accept-router-advertisements=yes

/ip address
add address=<例の計算機で求めたBRのv4アドレス> interface=ipipv6-v6plus network=\
    <例の計算機で求めたBRのv4アドレス>

/ipv6 address
add address=<例の計算機で求めたCEのv6アドレス> advertise=no interface=\
    bridge-ngn

いちおう例の計算機

1 Like

機種による差はあるかと思います(CCR2004はArm、CR1009はTileなので)。

また設定サンプルについてもありがとうございます。
こちらはv6プラス固定アドレスのものなのですが、基本的に同じなので大丈夫かと思っています。とはいえ、改めて見直してみることにします。

平日中は家族が在宅勤務のためネットワーク断が出来ないので、また来週以降試してみようと思います。

色々と助かります。

1 Like